This project is read-only.

UpdateMode Problem, quite strange

Nov 1, 2010 at 9:03 AM

Hi, first of alll, I want to say thank you, guys. I benefit much from this great project.

These days I found a problem, and worked for a long time but  still cannot get  solved. My problem is : I want to zoom and pan the Canvas coverd on the Multiscaleimage, so I write a new layer class followed the GeometryLayer,and depend on the SL Transform to scale and translate to react to zoom and pan. But I found when zoom to  level 7 or beyond, the canvas disappeared(set the canvas background color to red or other will see this ). More strange is sometimes the canvas can show up.This occured  when the Updatemode set to PanOnlyUpdate or TranslateUpdate. I cannot use the ElementUpdate since I am not going to redraw or update the objects on the canvas, and just depend on the SL Transform to scale and translate.

I found this thread, http://deepearth.codeplex.com/Thread/View.aspx?ThreadId=45145 , seems the same problem. But I am not sure, as my problem is not the wrong location of  objects or shapes, but the canvas disappeared. It's a SL bug?

So did anyone know how to handle this. It is really the biggest problem for my application now.

 

 

 

Nov 2, 2010 at 10:27 AM

I think this is a SL bug of Canvas. When canvas is a very large size, such as 40000px, it will work quite strange. The canvas width seems should less than Int16, about 32768. That's why it is alway show problems from level 7.

The bug is reported in SL2 but still here in SL4. links:

http://forums.silverlight.net/forums/t/193851.aspx

http://forums.silverlight.net/forums/p/61678/487051.aspx

I do not know what to do now