This project is read-only.

Map displays all black

Sep 10, 2008 at 8:29 PM
Just grabbed latest, set the prototype project as the startup project and the application runs showing the user controls (dashboard, polygon button, etc.) but the map is all black! I tried an earlier version I had and that happens as well. Am I missing something elementary? Could this be caused from either SP1 or being on a 64-bit machine (the latter does not make much sense to me)?
Sep 12, 2008 at 11:08 AM
in the download source... in the web application that hosts the DeepEarth Silverlight project there is a folder called "VE_files" have you got that in your project...?

it's like the tiles for the images, the map will not display without it
Sep 12, 2008 at 12:52 PM
That folder is in the project, however it was not in the bin/debug folder where the html page is that loads. So I moved it there and now 1 image is displayed, the world image from the map view. When I zoom in, I only zoom in on that image and it gets blurry.

Looking at the override method GetTileLayers(int tileLevel, int tilePositionX, int tilePositionY, IList<object> tileImageLayerSources) in DeepEarthTileSource, tileImageLayerSources is being populated correctly with the local URLs pointing to the 'VE_Files' folder and the images correctly (all though -1 is passed in as the tileLevel and there is no corresponding image for that). And it appears that tileImageLayerSources is also being populated with images from the correct URL from the VE servers ( ... so it appears the data is coming through correctly but my map does not update with this data.

Does someone have a working version that they can post to see if I can run it correctly? Thanks!
Sep 12, 2008 at 1:45 PM
I am on Vista 64Bit all windows updates installed and I have the latest version and it all works fine, I see the maps, I just run the project as it is and it all works
Sep 12, 2008 at 7:56 PM
still no luck here. I have tried downloading a new copy, setting the prototype project as the start up project and no luck, no map. I can copy the 've files' to the bin directory of the prototype project and then the .jpg file from the '8' directory is the only thing that gets displayed. I'll keep trying different things, not sure why it's not working.

dotnetnoobie, do you have SP1 installed for .net and VS?
Sep 12, 2008 at 10:02 PM
My experience with getting this to work is same as dotnetnoobies's - very easy.  Can you try it from a different computer and see if you have same experience.

Sep 12, 2008 at 11:28 PM
I agree that this should be very easy, it was once before. I will try on another machine as soon as I get a chance and let you know how it goes.
Sep 13, 2008 at 1:33 AM
Yes I have SP1 installed for VS 2008, you don't need to copy any files anywhere, the "VE_files" folder should be in the root dir of the "DeepEarthPrototypeWeb"

Sep 13, 2008 at 9:41 AM
Hey guys, looks like there is a way to remove those zoom levels below 512x512px (the reason we have those static files is this in the min size from the VE servers). Just tring to get the source code now and will get it put into the project, hope to fix those pan and zoom issues at the same time.
We expect to see a new release of Virtual Earth quite soon based on some of the twitter from MSFT, hopefully this will give us the new SOAP web services to do things like geocoding for this project.
Sep 13, 2008 at 11:38 AM
Hi soulsolutions,

do you have any idea when you may post the new source with the updates you mentioned...

I have stalled with what I would like to do due to the Pan & Zoom issue

no pressure, just wondering...?

.net noobie
Sep 16, 2008 at 12:45 PM
.net noobie,
I'm really keen to get these things fixed for people like yourself. I've been a little unwell and am busy catching up on a tonne of outstanding work this week.
I will make the time in the next two weeks as I want this project to be more usable by the end of the month.
Thanks for all your contributions.
Sep 16, 2008 at 1:05 PM
No Worries Dude, it is a great project,
easy the best mapping project for Silverlight so far I have found to use in my own projects.

Just hope I worked it out right and the info I have offered is atleast mostly correct... hehe :)
Sep 21, 2008 at 3:09 AM
Hi Soulsolutions

We really look forward to the solution for panning and zooming.

Sep 28, 2008 at 8:53 PM
Edited Oct 2, 2008 at 1:02 PM
Just grabbed the latest (15992) and had the same issue. Figured out that the error was an 'ImageError' with code 4001. Found this post to help me solve this problem:

To fix this issue, simply build the project, copy the 'TestPage.html' file from the 'DeepEarthPrototype /bin/debug' folder to the folder 'DeepEarthPrototypeWeb'. Then make sure you include that file in the DeepEarthPrototypWeb project and set this project as the startup project. Also, set the 'TestPage.html' as the start page. That fixed the problem for me!

EDIT: Forgot to mention that you also need to point the 'TestPage.html' file to the correct .xap location, such as: ClientBin/DeepEarthPrototype.xap
Sep 28, 2008 at 10:49 PM
Sounds like we need some better documentation on how to get going quickly and how to do simple things like interactions, shapes etc. I'm thinking a video would be the easiest?
What do you think?
Sep 29, 2008 at 12:24 AM
Edited Sep 29, 2008 at 5:10 PM
A quick how to video would be great! You can even use Silverlight streaming to host the videos and stream them! And then you can host the video easily! I can look into getting some tools to do videocasts, I know there are some free ones out there, just gotta google em.

Also, here is a codeplex video player that you can use.