This project is read-only.

Digitalizer - add new disabled

Mar 16, 2010 at 10:03 PM

I have run toolkit source code, and my digitalizer(all controls) is disabled. Why? Solutions? Ideas? Tnx

Mar 18, 2010 at 4:13 AM

The digitizer is designed to allow users to create and edit geometries into a choosen layer, the layerdefinition gives information like the style to the control. You need to add a list of layers to the control.

See a working example in the latest source code, live here:

(5th one down on the left)

I'm keen for feedback here, I think this control is very powerful but current not very intuitive or useable. I'd love for someone to spend the time to make it really consumer friendly.


Mar 18, 2010 at 10:00 PM

Tnx for reply,

uh I am still not going anywere :-( Now I have more questions.

First of all, why can't I use Digitalizer control in my custom application? After adding all refferences( without deepearth) I can see default map with my custom panel and buttons. After adding all references for Digitalizer control and Digitalizer tag, I am getting ERROR --> "Could not load file or assembly 'Microsoft.Maps.MapControl, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified." WTF? Removing Digitalizer tag and default application is back again :-)

In Toolkit demo Digitalizer control is showing ( as posted before ) but I am still not able to add layers.How to set Layers property? Any source code with examples?


Any help would be appreciated, Tnx