Digitizer + VS2010 + newbie = big headache...

May 23, 2010 at 7:39 PM

Hi all,

First of all, thank the team for these controls, you've done a great job !

I tried to import and use them inside a Silverlight Project in VS2010 and so far I must confess, that's not working :)

I give you all the steps I tried :

  • Imported Library and Toolkit Project in VS2010 and converted them (No upgrade to .NET 4.0)
  • Compiled the projects
  • Created a new Silverlight solution with Bing Map Silverlight Control v1.0.1.0
  • Add a reference to all DLLs in the "Debug" folder of Digitizer to my own Silverlight Solution
  • Add a reference in MainPage.xaml to Digitizer assembly (with namespace like in the demo) + function in CS code.
  • Tried to launch -> error because Toolkit Control are bound to v1.0.0.0 of Bing Map Silverlight Control
  • Change reference in the projet to v1.0.0.0
  • Tried to launch -> error "AG_E_UNKNOW_ERROR"
  • Added Key Resource in App.xaml for Credentials
  • Tried to launch -> error "AG_E_BAD_PARSER_TYPE" line 107 pos 121
  • Copy ResourcesDictionary part of  Page.xaml in the Demo Projet to my MainPage.xaml file
  • error -> cannot load the resource : component/Resources/CommonStyle.xaml
  • Set the compile mode of the CommonStyle.xaml file to Resource
  • same error

I'm stuck, is anyone getting the same error ? What sould I do to correct these to error (bad parser type and resource load) ?

Best regards, Edgar.


May 23, 2010 at 10:10 PM


If I launch the Demo of Digitizer in the Toolkit Project, it work fine.


May 24, 2010 at 3:18 PM

Sorry for the pain Edgar, the idea of breaking the controls into seperate projects and seperate dlls is to ease developer and prototyping. I believe the culprit is most like missing a common dll or the SL toolkit. With SL4 we can do much better with our resource dictionaries and I aim to reduce the number of dlls you need to have to use each control. Ideally it will be just two, a common and the specific toolkit control.

It would be nice to get a more meaningful message from SL but essentially the XAML is not parsing as one of the references doesn't exist. Try the following combination for the digitizer:

  • DeepEarth.Client.Common.dll
  • DeepEarth.Client.Controls.Digitizer.dll
  • DeepEarth.Client.Controls.ColorPicker.dll
  • DeepEarth.Client.Controls.GeometryStylePicker.dll
  • Microsoft.VirtualEarth.MapControl.dll
  • DeepEarth.Client.BingMaps.dll
  • DeepEarth.Client.Controls.MapGeometry.dll
  • GeoAPI.dll
  • NetTopologySuite.dll

    from: http://deepearth.codeplex.com/wikipage?title=Digitizer&referringTitle=Toolkit%20Control%20Matrix


  • May 24, 2010 at 9:39 PM


    I should have read this part before posting... I missed refrences to Color Picker, GeometryStylePicker and MapGeometry dlls... It works now, thank you so much.

    BTW may I suggest you to replace the name of the DLLs in the document, below the new ones :

    • DeepEarth.BingMapsToolkit.Client.Common.dll
    • DeepEarth.BingMapsToolkit.Client.Common.Entities.dll
    • DeepEarth.BingMapsToolkit.Client.Controls.Digitizer.dll
    • DeepEarth.BingMapsToolkit.Client.Controls.ColorPicker.dll
    • DeepEarth.BingMapsToolkit.Client.Controls.GeometryStylePicker.dll
    • Microsoft.Maps.MapControl and Microsoft.Maps.MapControl.Common
    • DeepEarth.BingMapsToolkit.Client.MapGeometry.dll

    GeoAPI and NetTopologySuite are OK.

    Best regards, Edgar