This project is read-only.

I don't see tiles...

Jul 16, 2008 at 9:07 PM
Hi all,

I am able to run the sample project successfully but I'm having trouble integrating the map in my own project.

Here is a screenshot of what I'm seeing:

I have the following xaml in my page:

<Grid Grid.Row="4" Margin="8,8,8,8" Visibility="Visible">
    <Rectangle RadiusX="8" RadiusY="8" Fill="{StaticResource brushContentPaneFill}" Stroke="{StaticResource brushContentPaneStroke}"/>
    <DeepEarth:Map x:Name="map" Margin="12,12,12,12"/>
              RenderTransformOrigin="0.5,0.5" />

And the following code in my page constructor:


new TileLayer(MapMode.Aerial));
new TileLayer(MapMode.Hybrid));
new TileLayer(MapMode.Road));
new PrototypeBehavior());
new MapModeBehavior());
dashboard.MapControl = map;

Am i missing something?





Jul 16, 2008 at 9:26 PM
I found the problem, I had to copy the VE_Files folder in my web project.
Jul 16, 2008 at 11:41 PM
Yes, the MSI control goes right down to 1x1 pixel while the tiles from the data provider, in this case VE with 512x512px, will not.
There is actually a task to impove the basic code to give the small local view for everything tilelayer, so you get a proper aerial, hybrid and road for example sub 512px.
Maybe one day the data provider will have these on their server, if so it should be a small change.
Aug 20, 2008 at 9:01 AM
Hi all,
I'm having the same problem! I don't see any tiles. Since i copied the "VE_files"-folder to deepEarth\Prototype\DeepEarthPrototype\obj\Debug, it's showing me the content of the folder ..
My first little "Hello World!" ;)
But, when I'm zooming no new tiles load in the MultiScaleImage. I covered the method Uri GetTile(..) in  TileLayer.cs and it's doing its work. The returned Uri seems to be correct but in the MSI nothing happens.
Shouldn't this solution work instantly? Or is there anything to do to get this running?
Maybe someone has a hint for me! ;)

Aug 21, 2008 at 9:25 AM
maybe some more infos .. i covered the projects of ...
part1 is working great and finally shows me all the tiles!!
part2 has the same problem like this project. i can see the multiscaleimage but nothing appears inside. no tiles :(

i tested the deepEarth.TileLayer.GetTile-Method and provided an local jpg-image to the msi. this image is displayed in the msi ...
i tested the same thing in the "Part2-project" .. and there the msi stays empty ... although the method gets called and returns the uri of my local jpg..

.. ok .. i found a point to start! there is a difference whether i provide a local or a network Uri. if i provide the local path ("C:\pic1.jpg") to the getTiles-Method the picture is displayed inside the msi
if i provide the real Uri ("http://localhost:1234/pic1.jpg") the msi stays empty ...

is this a known problem or has anybody any idea of how and why this happens?

i also see a difference between part1-project and part2/deepEarth. in part1 the image is downloaded and then provided to the msi. part2 and deepEarth don't do!
but isn't this (network-Uri & no download) the way it should work? anyhow, i think this is running .. but why don't for me?

a second issue is my development environment. i'm working on a virtual machine wired up through NAT. maybe that could be a problem?

i really need some help!


ps: if someone is wondering about me or my funny questions, i'm just a student doing some research for my diploma and i hope someone will help me!!! don't expect too much experience ;)
although i do my best!

Aug 21, 2008 at 4:07 PM
i got it ..
it worked indeed only locally  ...
maybe i've should set the webProject as startUP :D

i'm so happy .. btw very nice stuff u're doing here!!!!
Oct 2, 2008 at 4:36 PM
I have the same problem
I also can't see the tiles...
But I didn't copy the ve_files dir, I think this mayth be the problem
I Just don't have this directory, what is it? from where is it coming from?
Oct 2, 2008 at 9:02 PM
Have you checked out this post:

If that does not work, please let us know. thanks!
Oct 5, 2008 at 10:46 AM
I just downloaded a newer version (16092) and it worked,
Thanks anyway