This project is read-only.

RC0 breaking changes - anyone had a run at updating?

Sep 30, 2008 at 6:40 PM
Hi - has anyone taken a swing at porting DeepEarth to RC0 of Silverlight 2?  I tried a recompile and it is hitting on some breaking chnages, particularly around MouseEventArgs no longer having a Handled property.  It looks as though some of the EventBehaviorChain is relying on being able to flag MouseEnter events as handled.

Just wondering if anyone has had a go yet.
Sep 30, 2008 at 8:30 PM
I personally will not be upgrading to RC0 on my machine. I have heard that silverlight 2 will RTM sometime in October, and my guess would be around the PDC (late October).

RC0 is really meant for developers to get their apps ready for RTM and not really distribute the RC0 bits to the public. It would be a great idea for someone to see what changes are needed so we can easily migrate to RTM when it is released. If someone does decide to tackle this task, please report what has broken, just as rob has pointed out.
Sep 30, 2008 at 8:47 PM
I could manage to upgrade. These were the changes:

remove all args.Handled in all projects

In DeepEarthPrototypeWeb: remove silverlightdll refernce and add referene to RC0

In DeepEarthPrototype try to compile and correct the errors shown in Visual Studio:
- rename "Duration" to "GeneratedDuration"

- especially remove Attributes

In Dashboard.xaml locate <vsm:Style x:Key="spinButtonTemplate" TargetType="Button"> and remove the complete <vsm:Setter Property="Template"> tag and all its child.
This will remove the real nice Animation, but at least it works.

In DeepEarth Project create a folder named "themes" and move generic.xaml into it.

Sep 30, 2008 at 10:47 PM
Awesome Mikesnet!
I know we can do branches of code and stuff here, what do people think? should we branch for RC0 or just keep the list of changes, make the ones that don't effect Beta2 now, leaving the breaking changes for the actually release?
I don't want the project in a broken state for beta2.
Looks like we need to rework the dashboard.
Sep 30, 2008 at 11:18 PM
Edited Sep 30, 2008 at 11:18 PM
It's unlikely there will be many (hopefully not any) breaking API changes between RC0 and RTW, so I do think it's a good idea make the port to RC0 now.  After all, that is what the RC is for :)

I vote for at least branching, so that people who are hoping to have things ready near or at RTW can start their move via the RC0.
Oct 1, 2008 at 1:46 AM
mikesnet - thanks so much for the steps; I have done all of these and did manage to get it to compile, and have the page come up without errors.

But when it starts up, I get a black page with the controls around the sides. The coordinate readout in the lower-right corner reads -180.000, NaN. 

I noticed in another thread I am meant  to have a 'VE_Files' directory somewhere under the Silverlight project? I don't have any VE_Files directory anywhere. Maybe that's the issue?

I feel like I'm close :)
Oct 1, 2008 at 8:49 AM
If you have the lastest code you no longer need those local tiles.
Make sure you set the web project - with default.aspx as the startup project/document.

I'll see if I can get a full setup from scratch done on video this weekend.
Oct 1, 2008 at 4:39 PM
@soulsolutions - thanks for the tip on the local files.  I do have the web project with default.aspx as the startup project and document.

@mikesnet - was there anything else you changed?  Now that I am compiling and not getting any error messages, I'm kinda at a loss as to how to proceed.
Oct 1, 2008 at 7:33 PM
Edited Oct 2, 2008 at 1:03 PM
Have you checked out the post here:

To reiterate, this is what I did:
To fix this issue, simply build the project, copy the 'TestPage.html' file from the 'DeepEarthPrototype/bin/debug' folder to the folder 'DeepEarthPrototypeWeb'. Then make sure you include the 'TestPage.html' file in the DeepEarthPrototypWeb project and set this project as the startup project. Also, set the 'TestPage.html' as the start page.

Hope that helps!

EDIT: Forgot to mention that you also need to point the 'TestPage.html' file to the correct .xap location, such as: ClientBin/DeepEarthPrototype.xap
Oct 1, 2008 at 9:21 PM
@soulsolutions - are you sure the correct location for TestPage.html is in the root of the Web project? It references a xap in the same directory, rather than in a Clientbin subdirectory. If I edit it so that it references the xap properly, I get the same experience - app runs, Silverlight controls visible, no errors reported in IE7, and a black screen where the map should be.
Oct 12, 2008 at 4:04 AM
Any thing happening for the "RC0" version yet?
just wondering...? :)
Oct 12, 2008 at 8:08 AM
I've been concentrating on functionality.
You want to do the upgrade?

@robburke - sorry lost this thread, the control is not designed to run off those testpage.html things that are autogenerated. Get the latest code and either look athe web project in the prototype folder (default.aspx) or either the VE or OSM folders under "examples".

I'm going to record a getting started video right now.
Oct 12, 2008 at 8:04 PM
Edited Oct 12, 2008 at 8:06 PM
OK, I did a upgrade to "RC0" from the "Beta 2" version of Silverlight

Followed instructions from "mikesnet" but I also found a bug in Blend which is why I never got it to work before... but I worked it out.
also fixed/found out why you have to remove the template/style on the spin button in the dashboard and fixed it so it looks the same as the beta 2 version, basically worked out how to add the style again

also found a couple different things than "mikesnet" instuctions by reading the "Breaking Changes" docs and commented all the changes I made in the code so you can see where the differences are.

I still have a couple little things to update so will finish it later today and upload a version some where and provide a link to grab it.
will also write a few notes to go with the link to explain what I did different then what "mikesnet" added in previous post
Oct 12, 2008 at 11:28 PM
Edited Oct 12, 2008 at 11:29 PM
Welcome to the team dotnetnoobie! I should have added you earlier. You should now have access to commit the changes to the project.
Thanks for your work and clearly thanks to mikesnet also.