Important Note for GeometryLayer...

Coordinator
Jan 7, 2009 at 5:17 PM
The shape layer is still a work in progress.  So for you, when creating a layer for non-DeepPoints (e.g. Polygons, LineStrings) make sure the layer properties such as this:

                shapeLayer = new GeometryLayer(MapInstance) {ID = "POLYGONLAYER"};
                shapeLayer.HideElementsOnZoom = true;
                shapeLayer.UpdateMode = GeometryLayer.UpdateModes.ScaleTransform;

This makes this layer behave as it always has.  For DeepPoints, you can just create the layer and use the defaults.  This is actually how things always worked before, you just never had the option to change these properties.  I am currently working on getting the layers to work regardless of the Geometry types.


Jan 7, 2009 at 5:49 PM
The non-DeepPoint layers render fine now, but when the zoom is changed they move to the wrong locations.
Coordinator
Jan 7, 2009 at 6:58 PM
Do you mean the move to the wrong locations during zoom or when zoom is complete?  If the former, you shouldn't see the shapes during zoom when HideElementsOnZoom = true.  Please elaborate.
Jan 7, 2009 at 7:56 PM
It was in my code.  I am adjusting the line sizes based on zoom levels, so as you zoom in lines get thicker (and display properly).  I had to change some of my code, but it is working now.  Thanks!